Browser Functions not getting invoked in InPrivate Browsing Mode of IE?

Recently, I came across a situation in which I have to automate some scenario on private browsing mode of Internet Explorer (known as InPrivate Browsing). Although browser was getting identified in that mode, browser methods (like navigate,refresh etc) were not working (not throwing any error). After some searching, I came to know that in InPrivate Browsing Mode, all the extensions and add-ins are disabled due to which BHOManager Class Add-In is also disabled.

To enable browser methods in InPrivate mode of Internet Explorer, we need to enable add-ins. To do that, follow the below steps:

  • Go to Tools > Internet Options and click on Privacy tab.
  • Under the InPrivate section, uncheck the option that says ‘Disable toolbars and extensions when InPrivate Browsing starts’.
  • Click on OK button and start InPrivate session.

Image

Advertisements
Tagged with: , , , , , ,
Posted in Awesum Stuff

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog Stats
  • 168,130 hits
Categories

Enter your email address to follow this blog and receive notifications of new posts by email.

Join 796 other followers

%d bloggers like this: